stsadm DeploySolution command line error

Jul 2, 2013 at 12:49 PM
Edited Jul 2, 2013 at 12:53 PM
When I follow the installation instructions all works fine and without errors until I have to deploy the solution.
stsadm –o addsolution –filename "Image Upload Web Part.wsp"
is installed succesfully
stsadm –o deploysolution –name "Image Upload Web Part.wsp" –url [web application url] –allowcas –allowgac
Everytime is giving a command line error.

I'm unsure about what to set for [web application url].

I've tried several options:
http://intranet (as this is the SharePoint site)
http://server01 (Central administration site)
http://sspadmin/ssp (Shared Services Administration site)
http://intranet/images_places (picture library)
With en without quotes (")
But I'm probably mistaken what web application url I should be using.
Jul 2, 2013 at 1:17 PM
Additionally
stsadm -help deploysolution

stsadm.exe -o deploysolution
     -name <solution name>
     [-url <virtual server url>]
     [-allcontenturls]
     [-time <time to deploy at>]
     [-immediate]
     [-local]
     [-allowgacdeployment]
     [-allowcaspolicies]
     [-lcid <language>]
     [-force]
What I noticed is that "-allowgac" and "-allowcas" aren't listed.
But replacing these with "-allowgacdeployment" and "-allowcaspolicies" didn't solve it.
Jul 2, 2013 at 1:39 PM
Ok Solved this myself.
stsadm -o deploysolution -name "image upload web part.wsp" -url http://intranet/ -local -allowGacDeployment -allowcaspolicies
I don't know what part did the trick but I'm guessing it would be the capitals, or the lack of, in the name or the extra param "-local"
As for the capitals I found the solution name by running the addsolution command again. This gives an error with the exact solution name.